ConMas DesignerでConMasサーバーへのログインを試みたところ、上記のエラーが出てログインできない
<エラーダイアログ>
<原因>
ConMasサーバー内の設定の一部が、実態に即していない可能性があります。
<対処方法>
ConMas サーバー上の各アプリケーションフォルダに配置されているWeb.configファイル(※)の内容を確認して、Web.config内のパス指定箇所が実態に即しているか確認してください。
※ Web.configファイルについて
Web.configファイルはConMasフォルダの各アプリケーションフォルダ配下に存在します。
アプリケーションフォルダは、下記の3つがあります。
* ConMasAPI(外部連携APIご契約時)
* ConMasManager
* ConMasWeb
例えば、ConMasWebフォルダ配下のWeb.configファイル内の16行目、18行目付近にパスの情報を含むエレメントが存在しています。
<!-- クライアント設定ファイルパス -->
<add key="ClientSettings" value="C:/ConMas/SettingFiles/xml/" />
<!-- ユーザー個別設定格納パス -->
<add key="UserSettingPath" value="C:/ConMas/SettingFiles/xml/Users/" />
上記の様に、デフォルトの設定値は"C:"ドライブ想定となっています。
もし、ConMasフォルダをDドライブにインストールされている場合、
下記のような修正が必要です。
<!-- クライアント設定ファイルパス -->
<add key="ClientSettings" value="D:/ConMas/SettingFiles/xml/" />
<!-- ユーザー個別設定格納パス -->
<add key="UserSettingPath" value="D:/ConMas/SettingFiles/xml/Users/" />
上記の他にも、「◆◇◆ Log4net設定 ◆◇◆」の下にも、同様にパスを指定する箇所がありますので、同様の修正を行ってください。
また、ConMasManagerフォルダやConMasAPIフォルダ(APIオプションご利用の場合)配下の
Web.configファイル内の同様のパス指定箇所全てを、実態に合わせて変更してください。
なお、上記の対処方法で解消しない場合は、本ナレッジベースの対処方法で解消しなかった旨を添えてサポートWEBよりお問い合わせください。
# サポートWEB