【事象詳細】
Excelの「オプション」-「アドイン」でCOMアドインの「ConMas Excel COM Add-in」を確認すると「読み込み時の動作」に「読み込めませんでした。管理アドイン ローダーの初期化が失敗しました。」と表示される。
【原因】
動作環境とインストーラーの不一致、Excelプロセスの残存、アドインのdllが上書きされていることが原因として考えられます。
【対処方法】
下記の確認・対処をそれぞれご確認ください。
■インストールする端末の動作環境確認
下記マニュアルに記載の動作環境を満たしているかご確認ください。
# 参照マニュアル
i-Reporter 動作環境 > 動作環境 > ConMas EXCEL COM Add-in
■ConMas Excel COM Add-inの種別確認
インストールされているExcelについてビット数(※)を確認し、そのビット数に合ったアドインがインストールされていることをご確認ください。
Excelのビット数の確認は下記ナレッジベースの「原因3:ご利用のExcelのビット数とインストーラーのビット数が一致していない」項目をご確認ください。
# 関連するナレッジ
ConMas EXCEL COM Add-in が表示されない
※ 補足
ここでのビット数はWindows OSのビット数ではなく、Excelのビット数である点にご注意ください。
例えばWindows OSが64bitであっても Excelが32bit版をインストールしている場合は、アドインも32bi版をインストールする必要があります。
■Excelプロセスの残存確認
Excelアプリを終了しても、プロセスが残り続けている場合があります。
下記手順でプロセスが残存しているか確認し、残存している場合はアプリを完全に終了した後に、再度アドインの状態をご確認ください。
▼手順
-
「タスクマネージャー」を起動します。
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「プロセス」に「EXCEL.EXE」がある場合は、これを選択し「プロセスの終了」ボタンをクリックします。
■アドインのdll修復
何らかの理由により、弊社のアドインで配布しているdllが上書き・変更されている可能性があります。
この場合は、下記手順でdllを更新(修復インストール)してください。
▼手順
- Visual Studio 2010 Tools for Office Runtime がインストールされていることを確認してください。
- Windowsの「設定」→「アプリと機能」にて、Visual Studio 2010 Tools for Office Runtimeのアンインストールボタンクリックします。
- メンテナンスモードで「修復」を実行します。
- 修復後、「次へ」をクリックします。
上記で改善しない場合は、お使いの環境から一度 ConMas Excel COM Add-in をアンインストールしてから再インストールすることで事象が改善されるかご確認ください。
それでも改善しない場合は本ナレッジベースの対応で解消しなかった旨を添えてサポートWEBよりお問い合わせください。
# サポートWEB